Event ID 2012: While transmitting or receiving data, the server encountered a network error.
Applies to:
Windows Server 2012 R2
Windows 8.1
Windows Server 2012
Windows 8.0
Windows Server 2008 R2
Windows 7
Windows Server 2008
Windows Vista
In the System event log, you might notice:
Log Name: System
Source: srv
Event ID: 2012
Level: Warning
Computer: MachineName.fqdn
Description:
While transmitting or receiving data, the server encountered a network error. Occassional errors are expected, but large amounts of these indicate a possible error in your network configuration. The error status code is contained within the returned data (formatted as Words) and may point you towards the problem.
<EventData>
<Data>\Device\LanmanServer</Data>
<Binary>0000040001002C0000000000DC07008000000000840100C00000000000000000000000000000000034060000</Binary>
</EventData>
In Words
0000: 00040000 002C0001 00000000 800007DC
0008: 00000000 C0000184 00000000 00000000
0010: 00000000 00000000 00000634
C:\Windows\system32>err C0000184
for hex 0xc0000184 / decimal -1073741436
STATUS_INVALID_DEVICE_STATE ntstatus.h
The device is not in a valid state to perform this request.
1 matches found for "C0000184"
This basically is an error that the network driver is giving SRV on the send IRPs. It usually indicates a send is issued on a connection which is no longer in a state valid for sending. For example, send when a connection has not reached connected state will return STATUS_INVALID_DEVICE_STATE. If disconnect has been initiated, then the same error would be returned for further sends.
Cause:
====
1. Antivirus Filter driver interfering with the network stack
2. An outdated or bad network card driver
3. A bad NIC
4. Network Teaming software
5. WAN Optimization devices
6. Mismatched Speed and Duplex settings between the NIC and switch
7. A spotty connection to a switch port
Resolution:
=======
- Make sure that the firmware for the network switches/WAN accelerators and routers are up-to-date.
- Update the NIC firmware and driver.
- Update the NIC teaming software/driver.
- Update the Antivirus software or completely uninstall (for relief, and follow-up w/ the AV vendor)
- Manually set the speed/duplex
- Replace the network cable(s)
- Try a different switch port
- For the WAN optimizers, to try getting the packets from being modified, try using encapsulating the packets using IPsec.
Yong
Reference(s):