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"Peer Name Resolution Protocol" Service Could not be Started and HomeGroup Is not Working

SYMPTOM

You cannot join a HomeGroup with an error message "Windows cannot set up a HomeGroup on this computer. Error code: 0x80630801".

In addition, you may observe the issue that "Peer Networking Grouping" service cannot be started on this computer.

CAUSE

The error code 0x80630801 means PEER_E_CERT_STORE_CORRUPTED. The Identity Store has been corrupted.

(Location: "C:\Windows\ServiceProfiles\LocalService\AppData\Roaming\PeerNetworking\idstore.sst")

SOLUTION

To resolve this issue, we need to delete idstore.sst from the %appdata%\peernetworking folder. Please follow the steps below:

1. From an elevated CMD prompt, type in the following command:

Net stop p2pimsvc /y

2. Delete the following file:

"C:\Windows\ServiceProfiles\LocalService\AppData\Roaming\PeerNetworking\idstore.sst"

3. Reboot the computer.

Then you should be able to join HomeGroup.

REFERENCE

https://social.technet.microsoft.com/Forums/en/w7itpronetworking/thread/a85eaa65-d73a-4324-ad0c-e9a2c1469bd7

https://social.technet.microsoft.com/Forums/en-US/w7itpronetworking/Thread/6B5A72EB-6523-4AF9-85AB-3694D7CC457A

https://social.technet.microsoft.com/Forums/en/w7itpronetworking/thread/932e85c6-b141-4bc5-8be7-daa7e0ff714b

https://social.technet.microsoft.com/Forums/en/w7itpronetworking/thread/79ce2aad-0508-478b-b2d7-b89f70821c37

https://social.technet.microsoft.com/Forums/en/w7itpronetworking/thread/62491022-bd42-4e0e-bfaf-7fb172f70e78

Comments

  • Anonymous
    January 01, 2003
    DID NOT WORK FOR ME
  • Anonymous
    April 07, 2014
    The comment has been removed
  • Anonymous
    June 30, 2014
    I cannot start the Peer Name Resolution Protocol service either. It is preventing me from starting a HomeGroup. I received the error message: "Windows could not start the Peer Name Resolution Protocol service on Local Computer. Error 0x8009000f: Object already exists."

    Does anyone have an idea as to which object already exists? How do I delete the existing object? I have tried deleting the idstore.sst file without success. I have tried starting the computer in Safe Mode with Networking without success. I have tried a clean boot without success. No matter what I try, the service will not start.

    Any ideas?

    Technical Specifications:
    System Manufacturer: TOSHIBA
    System Model: Satellite S875
    System Type: x64-based PC
    OS Name: Microsoft Windows 7 Home Premium
    Version: 6.1.7601 Service Pack 1 Build 7601
    Processor: Intel(R) Core(TM) i7-3610QM CPU @ 2.30 GHz, 2301 Mhz, 4 Cores, 8 Logical Processors
    BIOS Version/Date: Insyde Corp. 6.80, 10/1/2013
    SMBIOS Version: 2.7
    Boot Device: DeviceHarddiskVolume1
    Installed Physical Memory (RAM): 16.0 GB

    Thank you, in advance, for your assistance.
  • Anonymous
    September 01, 2014
    Worked for me. Thank you.
  • Anonymous
    June 06, 2015
    I'm having this problem, too. The problem is the exact same as Don's above. The solution here does not work. The resolution is to delete the idstore.sst file so the computer can remake the file on reboot. The problem for me is that idstore.sst does not exist, at all, on my computer (my dad's, really). Can't delete what is not there.
  • Anonymous
    July 25, 2015
    This was the fix for me;

    Go to "C:ProgramDataMicrosoftCryptoRSA" and then rename "MachineKeys" folder to "MachineKeys-old".
    Create a new folder "C:ProgramDataMicrosoftCryptoRSAMachineKeys" and right click the "MachineKeys" folder , select "Properties" and click "Security" tab. then set "Full Control" permissions to "Everyone".

    Cheers,
    Matthew Kerfoot
    https://www.theovernightadmin.com
  • Anonymous
    July 31, 2015
    Fixed after two days of trying everything I could find on the web.
    I took Matthew Kerfoot (Thanks) advise, but instead of renaming and creating a new "MachineKeys" folder I set "Full Control" permissions to "Everyone" to the existing "MachineKeys" folder.
  • Anonymous
    August 09, 2015
    I set "Full Control" permissions to "Everyone" to the existing "MachineKeys" folder.
    This simple change worked for me too.
  • Anonymous
    August 18, 2015
    Full Control worked perfect!
  • Anonymous
    September 03, 2015
    Worked for me. Thanks Matthew!
  • Anonymous
    September 12, 2015
    And when the idstore.sst is missing? Nah this did not help me either.
  • Anonymous
    September 12, 2015
    NOW it's working :) As a last effort i tried giving MachineKeys folder a full access and now everything is ok. :) Ha ha THANKS!!!!
  • Anonymous
    September 22, 2015
    This worked for me, thanks!!
  • Anonymous
    October 04, 2015
    Matthew Kerfoot 26 Jul 2015 6:07 AM

    This was the fix for me;

    Go to "C:ProgramDataMicrosoftCryptoRSA" and then rename "MachineKeys" folder to "MachineKeys-old".
    Create a new folder "C:ProgramDataMicrosoftCryptoRSAMachineKeys" and right click the "MachineKeys" folder , select "Properties" and click "Security" tab. then set "Full Control" permissions to "Everyone".

    Cheers,

    Thank you Matthew. this worked. thanks again.
  • Anonymous
    October 15, 2015
    Patrick Mills solution worked for me too.
  • Anonymous
    October 15, 2015
    John M many thanks!
  • Anonymous
    October 20, 2015
    Many thanks. Spent hours trying to resolve this and the solution is simple if you know how!!
  • Anonymous
    November 16, 2015
    Thanks Matt, the solution worked for me also. The headache is relieved!~!!!!
  • Anonymous
    November 26, 2015
    Matthew Kerfoot solution worked for me!! thanks!!!
  • Anonymous
    December 12, 2015
    The folder was empty, even after turning on hidden files. HomeGroups and WorkGroups are a terrible idea that never worked right as with many other Microsoft ideas. Time to switch to Linux.
  • Anonymous
    December 15, 2015
    Sounds silly, but wiggling the mouse and hitting the spacebar during startup solved it for me.
  • Anonymous
    December 15, 2015
    That is, being stuck at the startup screen with no touch monitor, no usb keyboard or mouse.
  • Anonymous
    January 19, 2016
    machinekeys worked for me too - same issues - unable to share folder, couldn't login to this pc from another pc despite username and password being correct) - i wanted to be able to see a folder on PC no1. Joined homegroup fine now. Thx Matt!
  • Anonymous
    January 23, 2016
    I had 1 computer out of 5 that would not join my homegroup. After trying everything on every forum I could find, the solution that worked for me was to make sure all computers were on the same "type" of network connection. In my case 1 computer was connected via wireless adapter the rest via ethernet. After making an ethernet connection the computer joined immediately. Switching back to wireless made the homegroup disappear although it reappeared when ethernet connection was restored.
  • Anonymous
    February 03, 2016
    I've have been trying for months to set up a Homegroup since upgrading to Windows 10 and nothing worked. Until today - changing permissions on MachineKeys to Full Access for Everyone solved my problem. Thank you!!
  • Anonymous
    February 11, 2016
    The idstore.sst file also wasn´t there. Mattews's solution also worked for me. Thanks Matthew!!!
  • Anonymous
    February 14, 2016
    It works for me. thanks a lot.