Team Collection attach/detach would not finish.
Issue:
You may encounter an issue while performing detach or attach operation of Team Project Collection that would not finish. You would see progress bar moving endlessly without any error message.
Applies to:
TFS versions 2010 through 2015 RC.
Cause:
One of the possibility of this happening is ‘Visual Studio Team Foundation Background Job Agent’ service is not in running state.
Once you start the ‘Visual Studio Team Foundation Background Job Agent’ process would actually start and complete. You do not need to restart the attach/detach operation.
We have also seen scenario where in case of multiple application tiers, this can happen if Job agent is not running on a 2nd Application Tier so make sure to check status of Job Agent on all Application Tiers.
Please note, that during the readiness check you would see a warning stating same.
In case you get a log on error while starting the job agent, it could be related to the account credential service is running with. (Note, Background Job Agent is supposed to run with same account as the TFS Service).
Instead of changing the credentials from services manager, would highly recommend to use TFS Application Tier for same.
You can update Password, Change account or Reapply the credentials from TFS Admin Console.
TFS Admin Console > Application Tier.
Cheers!
Content created by – Romit Gulati