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Outlook Client with a SharePoint list prompts for the credential for a different URL

Outlook Client with a SharePoint list prompts for the credential for a different URL

You have a SharePoint site with FQDN URL in Alternate Access Mapping [AAM] particularly in Intranet zone. :

Internal URL Zone Public URL for Zone
https://default Default https://default
https://intra.contoso.com Intranet https://intra.contoso.com
https://inter Internet https://inter
https://custom Custom https://custom
https://extranet Extranet https://extranet

When you access the site as https://default and connect a List Library to your Outlook, it prompts for the credentials when you do F9 / Send and Receive to sync the data. In the credential prompt message box we can that that it is pointing to intra.contoso.com instead of https://default.

This behavior can occur regardless of whether you browse the site with URL in Default / Intranet / Internet / Custom / Extranet zone and connect the list / library to Outlook.

Cause:

The reason for this behavior is the way how SharePoint sends the AAM settings to the Outlook Client. SharePoint sends all the URLs for that site from AAM in below sequence to the Outlook Client:

Intranet zone URL
Default zone URL
Extranet zone URL
Internet zone URL
Custom zone URL

NOTE: SharePoint sends the URL in intranet zone first NOT the URL in default zone.

And in the same sequence Outlook uses the URL to connect to the SharePoint. That is, it first tries the Intranet URL and failover to subsequent URLs in above sequence.

Even without FQDN in the AAM we can confirm that this is how the SharePoint sends the URLs. In network trace we can see the below trace from SharePoint to the Outlook Client:

0320 61 78 42 75 6c 6b 44 6f 63 75 6d 65 6e 74 53 79 axBulkDo cumentSy
0330 6e 63 53 69 7a 65 3d 27 35 30 30 27 20 41 6c 74 ncSize=' 500' Alt
0340 65 72 6e 61 74 65 55 72 6c 73 3d 27 68 74 74 70 ernateUr ls='http
0350 3a 2f 2f 69 6e 74 72 61 2f 2c 68 74 74 70 3a 2f ://intranet /,http:/
0360 2f 72 61 6d 72 31 39 38 33 36 36 32 35 3a 36 30 /default/
0370 30 2f 2c 68 74 74 70 3a 2f 2f 65 78 74 72 61 6e ,http: //extran
0380 65 74 2f 2c 68 74 74 70 3a 2f 2f 69 6e 74 65 72 et/,http ://inter
0390 2f 2c 68 74 74 70 3a 2f 2f 63 75 73 74 6f 6d 2f /,http:/ /custom/
03a0 27 20 78 6d 6c 6e 73 3a 72 73 3d 27 75 72 6e 3a ' xmlns: rs='urn:

Workaround:

    There are 2 workarounds to this.

1st: Changing the AAM setting
If you are connecting the list or library to Outlook using Default zone URL then in AAM settings remove the FQDN entry in Intranet zone and add it to Internet or Custom zone.

2nd: Each user must add *.domain.com to the Local Intranet Sites dialog box

  • In Internet Explorer, click Tools, and then click Internet Options.
  • On the Security tab, click Local intranet, and then click Sites.
  • Click Advanced, and then type: *.domain.com or an IP address range (for example, *.contoso.com) in the Add this Web site to the zone box, where domain.com is your company and top-level domain names.
  • Click Add, click OK, click OK, and then click OK again to close the Internet Options dialog box.
  • Restart the computer.

Comments

  • Anonymous
    December 10, 2012
    The comment has been removed

  • Anonymous
    January 06, 2015
    Hello Ramesh, Thanks for posting this article, I am facing the same issue when I connect a list to Outlook, In my case I have URLs configured for Default (Custom Claims and NTLM), Intranet (NTLM) and Internet(NTLM), with 2 aams for default and intranet using http and https. Solution 2 doesn't work for me and when I try solution 1, edits AAM URLs moving Intranet Zone to Custom Zone and try access the URL post the change it gives 404 also when I goto Manage Web Applications I still see the zones as Default, Intranet and Internet. Can you please provide detailed instructions for solution 1.

  • Anonymous
    January 13, 2015
    Hello Ramesh, Not sure did you got a chance to look on the same. Thanks Prakul