A opção “Mostrar senha de recuperação” aparece desabilitada para um ou mais usuários
Por Helen Agard Fialho
Sintoma
A opção “Show Recovery Password” aparece desabilitada para um ou mais usuários.
Considere o seguinte cenário:
No Office 365, você habilita a opção “Habilitar Senha de Recuperação” na sua política de dispositivos do Exchange ActiveSync.
A política é aplicada no dispositivo do usuário, entretanto a opção “Mostrar senha de recuperação” está desabilitada no Outlook Web App (OWA) em “Email -> Opções -> Gerenciar eu mesmo -> Telefone -> Celulares”.
Causa
O dispositivo no qual a política está sendo aplicada não suporta o recurso “Recuperar Senha”.
Resolução
Este comportamento é por design.
O recurso “Recuperar Senha” é compartilhado entre o dispositivo e o servidor. No Office 365, se o dispositivo não suporta esse recurso, a opção “Mostrar Senha de Recuperação” estará desabilitada.
Informação Adicional
Quando a política do Exchange ActiveSync é aplicada, um elemento chamado PasswordRecoveryEnabled tem seu valor configurado para 1 e é enviado para o dispositivo. Se o dispositivo não suporta a recuperação de senha, ele ignorará a política, conforme descrito em: [MS-ASPROV]: Exchange ActiveSync: Provisioning Protocol.
No momento desta escrita, os únicos dispositivos que suportam a Recuperação de Senha são Windows Mobile 6.x
O Exchange ActiveSync oferece uma série de recursos, mas nem todos são suportados pelos diferentes dispositivos. Para dispositivos de terceiros, o fornecedor deve prover uma lista com as políticas do Exchange ActiveSync suportadas pelo dispositivo. (Por exemplo, Windows Phone ou iOS )
Referência: [MS-ASPROV]: Exchange ActiveSync: Provisioning Protocol