Support-Tip:(SYNC): stopped-server status during a synchronization
NOTE | A Support-Tip is the Problem / Cause / Resolution of a specific issue. |
APPLIES TO:
- Microsoft Identity Manager 2016 & Service Pack 1
- Forefront Identity Manager 2010 R2 & Service Pack 1
- Forefront Identity Manager 2010
ENVIRONMENT
- Microsoft Identity Manager 2016 Service Pack 1 (4.4.1237.0)
PROBLEM SCENARIO DESCRIPTION
- During the course of a Full Synchronization, we receive a stopped-server Run Status. In review of the Application Event Log, we find a BAIL error.
APPLICATION EVENT LOG EVENT ID 6306
Log Name: Application
Source: FIMSynchronizationService
Date: 4/28/2017 8:21:51 PM
Event ID: 6306
Task Category: Server
Description:
The server encountered an unexpected error while performing an operation for the client.
"WARNING: MMS(11900): ..\sql.cpp(5342): Error retrieving error
BAIL: MMS(11900): ..\sql.cpp(2716): 0x80004005 (Unspecified error)
BAIL: MMS(11900): ..\sql.cpp(2391): 0x80004005 (Unspecified error)
BAIL: MMS(11900): ..\storeimp.cpp(4996): 0x80004005 (Unspecified error)
BAIL: MMS(11900): ..\server.cpp(5769): 0x80004005 (Unspecified error)
Forefront Identity Manager 4.4.1237.0"
CAUSE
- Discovered that the Synchronization Service Account's password has expired.
RESOLUTION
- Reset the password on the Synchronization Service Account
ADDITIONAL INFORMATION ON THE STOPPED-SERVER STATUS
- FIM 2010 R2: Troubleshooting: "Stopped-Server" Error on the FIM Service Management Agent: https://social.technet.microsoft.com/wiki/contents/articles/11331.fim-2010-r2-troubleshooting-stopped-server-error-on-the-fim-service-management-agent.aspx
- Support-Info: (SYNC SERVICE): stopped-server: msidmCompositeType or Asynchronous Processing Scenario: https://blogs.msdn.microsoft.com/ms-identity-support/2013/09/30/troubleshooting-stopped-server-msidmcompositetype-or-asynchronous-processing-scenario/
- Support-Tip:(SYNC SERVICE): stopped-server: Troubleshooting Event ID: 6311 and 6401: https://blogs.msdn.microsoft.com/ms-identity-support/2012/05/15/fim-troubleshooting-stopped-server-event-id-6311-and-6401/
- Troubleshooting FIM: GalSync stopped-server on MA export: https://social.technet.microsoft.com/wiki/contents/articles/15526.troubleshooting-fim-galsync-stopped-server-on-ma-export.aspx