Support-Tip: (FIM Service MA): Stopped-Server: The export session has timed out waiting for responses
PRODUCTS INVOLVED
- Microsoft Identity Manager 2016
PROBLEM SCENARIO DESCRIPTION
- We are receiving the run status “Stopped-Server” when running the Run Profile “Export”. The Delta Import (Stage Only and the Full Import (Stage Only) both work successfully. In this scenario, we had 1,000 Pending Deletes that were EREs.
FOREFRONT IDENTITY MANAGER MANAGEMENT AGENT EVENT LOG
System.InvalidOperationException: The export session has timed out waiting for responses.
That amount of time can be configured using the exportActivityTimeoutInSeconds attribute of the resourceSynchronizationClient element within the Forefront Identity Management Synchronization Service application configuration file. The default duration is 600 seconds. If the volume of requests is very high, then using that attribute to increase the duration would be advisable.
However, one should investigate why no responses to export requests have been received within the default amount of time. Requests created on behalf of the Forefront Identity Manager Synchronization Service should be investigated to determine whether they are taking an unexpectedly long time to process.
CAUSE
- This was caused by an abundant number of Pending Deletes which turned out to be on the ERE Object Type.FIM Service Management Agent Exports are done in batches, and we had 1,000+ Pending Deletes, which was making this a really large batch to process and the FIM Service was timing out while talking to SQL Server with this large batch of Pending Deletes.
- Identified Another Cause: Just a bad batch that is being pushed out
RESOLUTION
- To resolve the issue, Disable Aggregate Processing and extend the exportActivityTimeoutInSeconds.
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ADDITIONAL INFORMATION / DOCUMENTATION
- Information on Aggregate Processing in TechNet: https://technet.microsoft.com/en-us/library/hh322883(v=ws.10).aspx
- Troubleshooting Stopped-Server Status: https://social.technet.microsoft.com/wiki/contents/articles/11331.fim-2010-r2-troubleshooting-stopped-server-error-on-the-fim-service-management-agent.aspx
- More information on tuning the FIM Service Processing in this FIM/MIM Support Team Blog Posting: https://blogs.technet.microsoft.com/iamsupport/2016/10/06/tuning-fim-service-ma-export-processing/