Support-Info: (PCNS): PCNS is not sending passwords to the Synchronization Service Engine
PRODUCTS / COMPONENTS INVOLVED
- Microsoft Identity Manager 2016 Service Pack 1
- Password Change Notification Service (PCNS)
PROBLEM SCENARIO DESCRIPTION
- Passwords are not being replicated to the Target Domain
NOTE |
If passwords are not making it from the Source Domain Controller to the Synchronization Service Manager GUI, enable verbose logging and see if you are getting an Event ID 6025 in the Application Event Log.PCNS: Troubleshooting Event ID 6025: https://social.technet.microsoft.com/wiki/contents/articles/4159.pcns-troubleshooting-event-id-6025.aspx |
CAUSE
- Password Synchronization was not enabled in the Synchronization Service Manager GUI
- Enable Password Synchronization in Tools > Options was not enabled (checked)
- Source and Target Management Agents were not setup
Source - Configure Directory Partitions
- Target - Configure Extensions
RESOLUTION
- Enable the Enable Password Synchronization option in Tools > Options
- Enable the Source Management Agent on Configure Directory Partitions
- Enable the Target Management Agent on Configure Extensions
ADDITIONAL INFORMATION
- PCNS Resource Wiki: https://social.technet.microsoft.com/wiki/contents/articles/2762.fim-password-synchronization-pcns-resource-wiki.aspx
- Microsoft Identity Manager 2016 Password Management: /en-us/microsoft-identity-manager/infrastructure/mim2016-password-management
- Microsoft Identity Manager 2016 Password Synchronization: /en-us/microsoft-identity-manager/infrastructure/mim2016-password-management#password-synchronization
- Deploy the MIM Password Change Notification Service on a domain controller: /en-us/microsoft-identity-manager/deploying-mim-password-change-notification-service-on-domain-controller