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You receive “Creation of Adapter FILE Configuration Store entries failed” when trying to configure “Biztalk Runtime” feature

Symptom

You get the following error message when trying to configure “Biztalk Runtime” feature at BizTalk configuration Wizard, or when trying to create a BizTalk Host at BizTalk Administration console:

"Creation of Adapter FILE Configuration Store entries failed.

Could not import a DTC transaction. Please check that MSDTC is configured correctly for remote operation. See the event log (on computer '<ServerName>') for more details."

 

Possible causes

1. Check that MSDTC service (Distributed Transaction Coordinator) is up and running in both SQL and BizTalk server.

2. Verify that MSDTC is configured properly in both SQL and BizTalk server:

a)    Click Start, click Run, type dcomcnfg and then click OK to open Component Services.

b)    In the console tree, expand Component Services,expand Computers,expand My Computer, expand Distributed Transaction Coordinator, and then click Local DTC.

c)    Right-click Local DTC and click Properties to display the Local DTC Properties dialog box.

d)    Click the Security tab.

e)    Ensure that each of the following four options are selected:

   Network DTC Access

   Allow Inbound

   Allow Outbound

   Authentication should be configured exactly the same in both servers

     3. Check that Windows Firewall is not blocking DTC communications. Add the following exception or disable Windows Firewall temporarily just to confirm/deny.

a)    Open “Windows Firewall with Advanced security” console

b)    Click Inbound Rules.

c)    In the Inbound Rules pane, right-click Distributed Transaction Coordinator * (as appropriate), and then click Enable Rule.

d)    Click Outbound Rules.

e)    In the Outbound Rules pane, right-click Distributed Transaction Coordinator * (as appropriate), and then click Enable Rule.

      4. In the event that SSO is clustered on Windows 2012 nodes ("Failover Cluster Manager" version: 6.2:), then make sure that EntSSO  account has Full Control permissions at  the cluster level:

a)    Open  “Failover Cluster manager” console.

b)    Right-click on the cluster name, and click on Properties

c)    On the “Cluster Properties” dialog box, click on “Cluster Permissions” tab.

d)    Grant Full Control Rights for the  EntSSO service account.

e)    Restart SSO cluster role.

Hope this helps.

Comments

  • Anonymous
    December 13, 2013
    Great ! it help me and save my time  nice article....

  • Anonymous
    December 16, 2013
    Number 4 helped me.  What a lifesaver

  • Anonymous
    October 14, 2014
    The clustered SSO on Windows 2012 - a life saver.  Thank you.

  • Anonymous
    December 18, 2014
    This is a good find..No 4 help and saved the day!!

  • Anonymous
    July 15, 2015
    THX for No 4, that helps a lot !!! :-)

  • Anonymous
    July 27, 2015
    Number 4 did the trick - thanks a lot!

  • Anonymous
    February 04, 2016
    No.4 life saver

  • Anonymous
    May 09, 2016
    Number 4 helped me. What a lifesaver! ;-)