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Configuring the CRM 4.0 Outlook Client or logging into Microsoft Dynamics CRM 4.0 fails with HTTP - Status 400: Bad Request

You might have seen the following problem in the past when you wanted to configure the CRM 4.0 Outlook client.

Problem
During the Dynamics CRM Outlook client configuration the wizard may fail with the following error after entering the CRM website URL and pressing “Next”:

“HTTP - Status 400: Bad Request”

The same error can occur when the user tries to log into CRM using the Outlook client.

 

Conditions

  1. The issue does only occur if you are using Kerberos authentication tokens.
  2. The user trying to configure the client is member of multiple AD security groups.
  3. You are using Internet Information Services 6.0 or 7.0

 

How to identify the issue

When you run the Fiddler Web Debugger Tool (https://www.fiddler2.com/fiddler2/version.asp) on the Outlook Client while trying to configure the client, the trace shows that a request to CrmService.asmx is replied by the IIS with:

HTTP/1.1 400 Bad Request
Content-Type: text/html
Date: Wed, 03 Feb 2010 15:03:15 GMT
Connection: close
Content-Length: 46

<h1>Bad Request (Request Header Too Long)</h1>

 

Cause

The cause for the “Request Header Too Long”  is external to CRM.

If the user is member of many Active Directory security groups then the Kerberos authentication token that is sent by the client to the IIS Server  may exceed the size limit for the authentication header enforced by the Internet Information Server. By default the maximum size for the authentication header is limited to 16384 bytes.

 

Resolution
As described in the following KB

CLM: HTTP Bad Request (Request header too long)
https://support.microsoft.com/default.aspx?scid=kb;EN-US;955585

you either need to reduce the number of security group memberships for the CRM user, or you should carefully increase the values for the following maximum request limits:

 

[HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\HTTP\Parameters]
MaxFieldLength
MaxRequestBytes

It is strongly recommended that you do evaluate the size limit you need before you raise the default size, because raising this value can cause excessive memory consumption by the IIS application pools.

Additional information about the settings options of the HTTP.sys and the Internet information server can be found under.

Http.sys registry settings for IIS
https://support.microsoft.com/kb/820129/en-us

 

Additional content
How to force Kerberos to use TCP instead of UDP in Windows.
https://support.microsoft.com/kb/244474

 

Greetings,
Alex