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"Error HRESULT E_FAIL has been returned from a call to a COM component" using TFS201 Team Web Access

Following comes from Senior Support Engineer Nitish Nagpal.

 

Problem:
One of my customers was facing an issue with the TFS2010 Team Web Access in a collection that  was ported over from another TFS 2010 install. They were not experiencing this issue with newly created projects on their server. While trying to edit a query in Team Web Access (TWA), they got the following error message: “Error HRESULT E_FAIL has been returned from a call to a COM component.”

This issue arises when:
1. They try to create a new work item – user story, bug, task etc.
2. They try to edit an existing query.
3. They try to open a work item from a query result set.
4. They search for a work item by the WI ID.

Troubleshooting:
Customer tried clearing team system web access cache, and they also tried to re-stamp the cache by invoking the StampWorkItemCache  by using the following URL but it didn’t work <myserver>/:8080/tfs/<collection_name>/WorkItemTracking/v3.0/ClientService.asmx

 

Resolution:
Finally, we launched SQL Server Management Studio and connected to the collection database containing data for the affecting team project. In a new query window we did a exec StampDb. After we ran stamp db stored procedure, it did reset the stamp, so that next time “client” connected to the server, it re-download the metadata.

Cause:
In some cases, metadata is locked by the client thread and deleting metadata usually doesn’t work (such as the metadata locked by web access thread). Running stampdb force them to drop old metadata cache

Comments

  • Anonymous
    May 10, 2012
    Thanks, I had this issue too and this solution worked perfectly.

  • Anonymous
    October 03, 2014
    Hi I've had a problem too on my Roxio game cap hd pro it comes up saying the same thing when I try and upload it to YouTube what's happened and what do I do about it.  

  • Anonymous
    February 13, 2015
    The comment has been removed

  • Anonymous
    June 10, 2016
    What is the solution? I can't read anything about a solution in this article. Just a description of the problem.

    • Anonymous
      June 10, 2016
      REPOSTTroubleshooting:Customer tried clearing team system web access cache, and they also tried to re-stamp the cache by invoking the StampWorkItemCache  by using the following URL but it didn't work http://[myserver]/:8080/tfs/[collection_name]/WorkItemTracking/v3.0/ClientService.asmx&#8221Resolution:Finally, we launched SQL Server Management Studio and connected to the collection database containing data for the affecting team project. In a new query window we did a exec StampDb. After we ran stamp db stored procedure, it did reset the stamp, so that next time (client) connected to the server, it re-download the metadata.Cause:In some cases, metadata is locked by the client thread and deleting metadata usually doesn’t work (such as the metadata locked by web access thread). Running stampdb force them to drop old metadata cache