Cannot use “AD authoritative restore” to restore a specific user account
問題描述
=============
1. A網域的UserA透過ADMT方式轉移至B網域
2. 嘗試於A網域進行授權式還原UserA帳號
3. 還原過程都是成功的,在沒接上網路線的狀況下也可以正常看到該User
4. 接上網路線後會發現此User帳號會自動被刪除
問題原因
=============
由於ADMT會確保搬移到目的端網域(B網域)的帳號不會同時存在於來源端的網域
所以我們在A網域DC進行授權式還原時 , 只要將DC接回網路線時該帳號就會自動被刪除
替代解決方式
=============
是於來源網域DC上透過ADRestore.exe此工具將刪除的User帳號來解決此問題
參考資料
=============
Create a Rollback Plan
https://technet.microsoft.com/en-us/library/cc974385(WS.10).aspx