Dynamics CRM Online 上で表示時間が1時間ずれる
みなさん、こんにちは。
今月のホットなトピックとして、Dynamics CRM Online のタイムゾーンについてお知らせします。10月中旬より Dynamics CRM Online 上の表示時間が1時間ずれていると報告がございました。
[現象]
- Dynamics CRM Online 上の表示時間が1時間ずれて表示される
- 時間指定した際のデータ集計がおかしい
- 10月の中旬くらいから事象が発生している
[環境]
- Microsoft Dynamics CRM Online Spring ‘14 Update Rollup 1 Update 5 (ビルド番号: 6.1.1.1521) 以降
https://support.microsoft.com/kb/3002347
[原因]
ユーザー様のタイムゾーンが、「(GMT+08:00) イルクーツク (RTZ 7)」になっています。
日本を含めたアジア地域でご登録頂いた Dynamics CRM Online サーバーは、アジアのある都市のデーターセンターで管理されております。このデーターセンターで作成された Dynamics CRM Online の全ユーザーのデフォルトタイムゾーンは、「イルクーツク」となっております。
今回、ロシア政府によりこのイルクーツク時間の定義が変更されたため、10月中旬のあるタイミングで Dynamics CRM Online 製品側のイルクーツク時間定義を日本時間と同じGMT+9 から GMT+8 に変更する修正が行われました。よって、「イルクーツク」時間をそのままお使いのユーザー様は、時間が1時間ずれる事象が発生します。
[解決方法]
表示時間に影響が出たユーザー様は、「(GMT+08:00) イルクーツク (RTZ 7)」から、「(GMT+09:00) 大阪、札幌、東京」に変更してください。
追記: 今回のイルクーツクのタイムゾーン変更により、新規の Dynamics CRM Online 組織、または既存の組織内で作成した新規のユーザーのタイムゾーンは、「(GMT+9) ソウル」となります。以前は、「イルクーツク」が GMT+9 リストの一番最初でしたが、現在は GMT+9 に「ソウル」が最初にリストされるため、デフォルトのタイムゾーンが変更になります。
- 野田 良二