【サポートトピック】プラグイン登録ツールで登録されているプラグイン一覧が表示されない
みなさん、こんにちは。
Microsoft Dynamics CRM 2015 ソフトウェア開発キット (SDK) ツールの 「プラグイン登録ツール」 で Dynamics CRM 2015 組織に接続した際、登録したプラグイン一覧が表示されない問題がありますので共有いたします。
[現象]
- プラグイン登録ツール (SDK 2015) を起動し、Dynamics CRM 2015 (設置型、オンライン) 組織に接続しても、登録したプラグイン一覧が表示されず、空白のウィンドウのまま表示される
- 日本語の Windows OS 上でプラグイン登録ツールを起動し、接続すると一覧が表示されない
- 英語 Windows OS 上でプラグイン登録ツールを起動、接続すると一覧が表示される
[手順]
- Microsoft Dynamics CRM Software Development Kit (SDK) for CRM Online and on-premises CRM 2015 をダウンロードします
https://www.microsoft.com/en-us/download/details.aspx?id=44567 - SDK\tools\PluginRegistratoin フォルダ下にある、PluginRegistration.exe を実行します
- 画面左上の [CREATE NEW CONNECTION] をクリックします
- 設置型の場合には On-Premise を、オンラインの場合には Office 365 を選択して、必要情報を入力します
- 接続後に組織が読み込まれますが、登録されているプラグイン一覧が表示されません
[原因]
製品の問題として現在調査中です
現在のところ (2015 年 4 月中旬) 、SDK 2015 は英語版のみのリリースであり、このプラグイン登録ツールも英語 UI のみ対応です。当初は複数言語の対応予定のためにフォルダー (ja-jp 等) が作成されましたが、最終的に複数言語対応はされませんでした。以下に記載した解決方法で対処することで、英語 UI で実行することが出来ます。
[解決方法]
SDK\Tools\PluginRegistration\ja-jp 下の日本語言語用 DLL ファイルが原因と考えられます。以下のどちらかの対処をすることで、英語の表示ですが、プラグインの一覧を表示することが出来ます。
- en-us フォルダ下の Microsoft.XrmTooling.CrmConnectControl.resources.dll ファイルを ja-jp フォルダ下に配置する
- SDK\Tools\PluginRegistration\ja-jp フォルダ名を変更する。変更することにより、英語言語がデフォルトとなり en-us フォルダ下の dll が読み込まれます。
- 野田 良二