KB938994 - The discovery process does not find computers that are present in your domain in Operations Manager 2007
Another recent KB article published https://support.microsoft.com/kb/938994/en-us
SYMPTOMS
When you use the "Computer and Device Management Wizard" in Microsoft System Center Operations Manager to perform computer discovery, the discovery process does not find computers that are present in your domain. When this issue occurs, the wizard may stop responding. Or, computers may appear in the queue as incomplete in Operations Manager 2007.
Additionally, the following error may be logged in the Microsoft SQL Server error log:
Msg 15404, Level 16, State 19- Could not obtain information about Windows NT group/user 'NTGROUP\AccountName', error code 0x5. The statement has been terminated.
CAUSE
This issue may occur when the account under which the SQL Server Agent (MSSQLSERVER) service is running has insufficient permissions to access Active Directory Domain Services (AD DS).
RESOLUTION
To resolve this issue, make sure that the SQL Server Agent service runs as a domain account or as a computer account that can access AD DS.
1.Click Start, click Run, type services.msc, and then click OK.
2.In the Services Microsoft Management Console (MMC) snap-in, right-click SQL Server Agent (MSSQLSERVER) in the list of services, and then click Properties.
3.On the Log On tab, change the SQL Server Agent account to an account that has sufficient permissions to access AD DS.
Note By default, the following accounts have sufficient permissions to access AD DS:
•A domain-level user account
•A local-system account that has Read All Properties permissions at the domain level
4.Click OK for each dialog box that appears, and then restart the SQL Server Agent service.
For more information, click the following article number to view the article in the Microsoft Knowledge Base:
331951 (https://support.microsoft.com/kb/331951/) Some applications and APIs require access to authorization information on account objects