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Event 315 with error 2114 on startup

Recently some customers reported then got event 315 with error 2114 on every system startup. The printers and the system both work fine. The only problem is the event with error when the system starts up each time.

The detailed log is similar as following:

Log Name:      Microsoft-Windows-PrintService/Admin
Source:        Microsoft-Windows-PrintService
Date:          6/10/2011 4:47:13 PM
Event ID:      315
Task Category: Sharing a printer
Level:         Error
Keywords:      Classic Spooler Event,Printer
User:          SYSTEM
Computer:      BobbyC-PC
Description:
The print spooler failed to share printer HP Photosmart C7200 series BT with shared resource name HP Photosmart C7200 series. Error 2114. The printer cannot be used by others on the network.
Event Xml:
< Event xmlns="https://schemas.microsoft.com/win/2004/08/events/event">
  <System>
    <Provider Name="Microsoft-Windows-PrintService" Guid="{747EF6FD-E535-4D16-B510-42C90F6873A1}" />
    <EventID>315</EventID>
    <Version>0</Version>
    <Level>2</Level>
    <Task>30</Task>
    <Opcode>12</Opcode>
    <Keywords>0x8000000000000820</Keywords>
    <TimeCreated SystemTime="2011-06-10T20:47:13.118441500Z" />
    <EventRecordID>12</EventRecordID>
    <Correlation />
    <Execution ProcessID="1612" ThreadID="1568" />
    <Channel>Microsoft-Windows-PrintService/Admin</Channel>
    <Computer>BobbyC-PC</Computer>
    <Security UserID="S-1-5-18" />
  </System>
  <UserData>
    <ShareFailed xmlns:auto-ns3="https://schemas.microsoft.com/win/2004/08/events" xmlns="https://manifests.microsoft.com/win/2005/08/windows/printing/spooler/core/events">
      <Param1>2114</Param1>
      <Param2>HP Photosmart C7200 series BT</Param2>
      <Param3>HP Photosmart C7200 series</Param3>
    </ShareFailed>
  </UserData>
< /Event>

Root cause:

The spooler just uses the Server Service for sharing the printers. If the server service has not fully initialized when the spooler initializes and wants to share the printers, the error will be logged.

Resolution:

Check the server service and make sure there are no dependent services that have been changed from default settings.

In addition, make sure the printer driver is up to date.

More information:

I know that Lexmark has used DCOM in the past for monitor software and had issues. If you have a bunch of Lexmark devices, I'd check for DCOM errors (no clue if these are in the System event logs any more) and also verify if the Lexmark devices are using monitor software.

Comments

  • Anonymous
    April 15, 2012
    As a basic user I have no idea what a server service is on my home network. Yes the info in this article confirmed what is on my computer event viewer. But does nothing to help me solve my problem.

  • Anonymous
    May 15, 2012
    Event 315 with error 2114. Start Services.msc and change "Computer Browser" to start automaticaly. This solve my problem.

  • Anonymous
    October 21, 2012
    I had this problem when I turned on my printer before I started my computer.  When I start my computer first and then turn on the printer Event 315 with error 2114 disappears.  

  • Anonymous
    December 16, 2012
    Like Michael I'm just a basic user but don't think I have a home network. I have 1 PC & 1 printer,  I don't share with anyone. How do I resolve this error at every boot?

  • Anonymous
    June 06, 2013
    J.H. de Baat's suggestion (12 May 2012) worked beautifully for me. Many thanks!

  • Anonymous
    November 19, 2013
    Same issue. Changed the HP UDP driver from 5.6.5 to 5.7.0, now working.

  • Anonymous
    November 24, 2013
    I had the same problem and I tried the solution from J.H. de Baat and it worked fine! Thank you!

  • Anonymous
    January 20, 2014
    I had the same problem and I tried the solution from J.H. de Baat and it worked fine! Thank you so much.Amazing how yellow warnings and red errors gradually creep into event log the older Windows 7 gets!

  • Anonymous
    April 04, 2014
    The solution from J.H. Baart solved my problem too: "Start Services.msc and change "Computer Browser" to start automatically". Thank you.

  • Anonymous
    April 10, 2014
    The solution from J H Bart solver my problem

  • Anonymous
    May 28, 2014
    Indeed, J.H. Baarts solution worked just fine. Hats off to you, good Sir.

  • Anonymous
    November 23, 2015
    Thank you.
    This solution from J.H. de Baat solved my Problem, too!

  • Anonymous
    November 23, 2015
    Thank you.
    This solution from J.H. de Baat solved my Problem, too!