Azure Backup service version and Microsoft Azure Recovery Services Agent versions do not match
This article describes the symptoms and resolution for an issue that occurs in these two scenarios:
- Back up files and System State by using the Microsoft Azure Recovery Services Agent
- Back up data to Azure by using System Center Data Protection Manager or Azure Backup Server
Original product version: Azure Site Recovery, Azure Backup
Original KB number: 4096064
Symptoms
The following error message appears on the Errors tab of the Job Details dialog box that corresponds to a failed Backup job on the Azure Recovery Services Agent console, Data Protection Manager, or Azure Backup Server console for Azure Recovery Services Agent version numbers below 2.0.9083.0.
Azure Backup service version and Microsoft Azure Recovery Services Agent do not match. Please install the latest version of Microsoft Azure Recovery Services Agent from the Microsoft Download Center (https://go.microsoft.com/fwlink/?linkid=225925). If the issue persists, please contact Microsoft Support (0x1FBD3).
The following is a sample of this error:
Cause
This issue occurs because the Microsoft Azure Recovery Services Agent is outdated.
Resolution
To resolve this issue, follow these steps:
Close the Microsoft Azure Recovery Services Agent console.
Important
If the server or the server's proxy has limited Internet access, follow steps 2 to 4. Otherwise, go to step 5.
To configure the firewall settings as mentioned earlier, run the following command from an elevated command prompt:
net stop obengine
Make sure that the firewall settings on the server or proxy are configured to allow the URL that is appropriate to the Azure cloud that you are using.
Run the following command from an elevated command prompt:
net start obengine
Download the latest version of Azure Backup Agent to the server that has the issue.
Run the installer. The Microsoft Azure Recovery Services Agent Upgrade Wizard opens.
Click Next.
Click Upgrade.
The final confirmation screen indicates that Azure Backup Agent has been successfully updated.
Close the wizard.
Open the MARS Agent Console.
In the right side of the console, click Back up Now in the "Actions"**** pane, and then check if Backup is running successfully.
Next steps
There could be other servers in your Backup environment that contain an Azure Recovery Services agent that is older than version 2.0.9083.0 and may face a similar issue. Follow the guidance in Updating Azure Backup agents to identify and update Azure Recovery Services agent.
Contact us for help
If you have questions or need help, create a support request, or ask Azure community support. You can also submit product feedback to Azure feedback community.