Sdílet prostřednictvím


Problémy se servery oblastí ve službě Azure HDInsight

Tento článek popisuje kroky řešení potíží a možná řešení problémů při interakci s clustery Azure HDInsight.

Scénář: Nepřiřazené oblasti

Problém

Při spuštění hbase hbck příkazu se zobrazí chybová zpráva podobná této:

multiple regions being unassigned or holes in the chain of regions

Z hlavního uživatelského rozhraní Apache HBase můžete zobrazit počet oblastí, které jsou nevyvážené na všech serverech oblastí. Potom můžete spustit hbase hbck příkaz, abyste viděli díry v řetězci oblastí.

Příčina

Díry můžou být výsledkem offline oblastí.

Rozlišení

Opravte přiřazení. Podle následujících kroků přeneste nepřiřazené oblasti zpět do normálního stavu:

  1. Přihlaste se ke clusteru HDInsight HBase pomocí SSH.

  2. Spuštěním příkazu se připojte hbase zkcli pomocí prostředí ZooKeeper.

  3. Spusťte nebo rmr /hbase-unsecure/regions-in-transition spusťte rmr /hbase/regions-in-transition příkaz.

  4. Ukončete prostředí zookeeper pomocí exit příkazu.

  5. Otevřete uživatelské rozhraní Apache Ambari a restartujte službu Active HBase Master.

  6. Spusťte hbase hbck příkaz znovu (bez dalších možností). Zkontrolujte výstup a ujistěte se, že jsou přiřazeny všechny oblasti.


Scénář: Servery mrtvých oblastí

Problém

Servery oblastí se nespustí.

Příčina

Několik rozdělení adresářů WAL.

  1. Získání seznamu aktuálních seznamů WAL: hadoop fs -ls -R /hbase/WALs/ > /tmp/wals.out.

  2. wals.out Zkontrolujte soubor. Pokud existuje příliš mnoho adresářů rozdělení (počínaje *-rozdělením), server oblasti pravděpodobně selhává kvůli těmto adresářům.

Rozlišení

  1. Zastavte HBase z portálu Ambari.

  2. Spusťte hadoop fs -ls -R /hbase/WALs/ > /tmp/wals.out , abyste získali aktuální seznam walů.

  3. Přesuňte adresáře *-rozdělení do dočasné složky splitWALa odstraňte adresáře *-rozdělení.

  4. Spusťte hbase zkcli příkaz pro připojení s prostředím zookeeper.

  5. Spustit rmr /hbase-unsecure/splitWAL.

  6. Restartujte službu HBase.

Další kroky

Pokud jste problém neviděli nebo nemůžete problém vyřešit, navštivte jeden z následujících kanálů, kde najdete další podporu:

  • Získejte odpovědi od odborníků na Azure prostřednictvím podpory komunity Azure.

  • Spojte se s @AzureSupport – oficiálním účtem Microsoft Azure pro zlepšení uživatelského prostředí. Propojení komunity Azure se správnými prostředky: odpovědi, podpora a odborníci.

  • Pokud potřebujete další pomoc, můžete odeslat žádost o podporu z webu Azure Portal. V řádku nabídek vyberte možnost Podpora nebo otevřete centrum nápovědy a podpory . Podrobnější informace najdete v tématu Vytvoření žádosti o podpora Azure. Součástí předplatného Microsoft Azure je přístup ke správě předplatného a podpora fakturace. Technická podpora se poskytuje prostřednictvím některého z plánů podpory Azure.